Seacom Issues
Incident Report for SalonBridge
Resolved
We believe that the underlying issue is being bypassed or resolved. We will continue to monitor the situation.
Posted Mar 15, 2024 - 09:12 SAST
Update
The issue persists and appears to be fibre cable-related (Seacom or otherwise). We continue to monitor the situation but clients who are experiencing issues are encouraged to try using mobile data to access SalonBridge as an alternative which may bypass the undersea cable providers.

https://downdetector.co.za/
Posted Mar 14, 2024 - 14:24 SAST
Identified
Seacom is experiencing network related issues which may effect some clients access to SalonBridge.
Posted Mar 14, 2024 - 13:48 SAST